PDA

Просмотр полной версии : Apache 2.0.50 + Tomcat 5.0.27



Alien456
25.08.2004, 16:41
Еще раз прошу прощения за ламерство и опять надеюсь на помощь.

Хочу: чтобы апач обрабатывал html, а jsp передавал томкату. И чтобы все это было на 80 порту.

Пыталась:
1. Делала все по инструкции http://www.devside.net/web/server/windows/Tomcat
Получила томкат, висящий на 8080, и апач на 80. Это у меня и так было. (А зачем, собственно, я это делала? Зачем мне вообще нужны были коннекторы, если томкат и так работал на 8080)
2. Нашла еще инструкцию
http://www.dynamicobjects.com/d2r/archives/002574.html
В ней рассматривается томкат 5.0.18
Предлагается в server.xml найти закомментированую строчку
<Context path="" docBase="ROOT" debug="0"> и добавить туда
<Context path="" docBase="APACHE_DIR/htdocs" debug="0" reloadable="true" crossContext="true"/>
Но этой строчки в server.xml нет, и я даже знаю почему.
Читаю по аресу http://www.coreservlets.com/Apache-Tomcat-Tutorial/#Enable-Root-Context
что эту строчку надо указывать только для версий с 4.1.12 до 5.0.19. А у меня 5.0.27. Если я все равно добавляю эту строчку, томкат не работает. Если не добавляю, тоже не работает, видимо не знает, где у него docBase.
Интуитивно я догадываюсь (эти догадки ни на чем не основаны, только интуиция), что нужно каким-то обазом указать ему docBase, и все будет хорошо. Каким образом - нигде не написано.

Убила на все это почти два дня. Результата не достигла. Надеюсь на помощь...
Заранее спасибо.

Deady
26.08.2004, 09:30
храни хтмл в каталогах апача, http://www.developing.ru/forum/viewtopic.php?t=1120&sid=de01f9eeed2855074e0e76486eb0fc3d - посмотри здесь, как настроить апач на переадресацию запросов томкату.
сделай переадресацию на адрес http://server/java/. Потом просто подправишь все ссылки на jsp, и все.
В итоге:
http://server/ - апач
http://server/java/ - томкат

Виталий
16.09.2005, 18:58
Ну как, проблема уже решена ? :?: